Skip to main content

Posts

Showing posts from June, 2009

Firefox Add ons

How to make Firefox addons compatible with the newest release.

Everybody likes to try out the newest version of Firefox. At the time I was writing this Firefox 3.1 beta 1 was available. When you install it you will find some of your existing Firefox add-ons may have already been updated to work with the new version. Others won’t install at all.

Don’t be surprised if some of the add-ons you modify to be compatible, bring Firefox to its knees. They don’t let you install older versions for a reason. But so I’ve had no problems at all.

Step 1 – Downloading the add-on


Locate the add-on you want to install. If it’s on the official Firefox add-on page you’ll have to click “See All version” to be allowed access to the .xpi. Right click on the now clickable “Add to Firefox” button and choose save target file as.

Step 2 – Extracting the add-on.

Locate the add-on you just saved. You should be able to open the .xpi file with your favorite compression utility. I use Power Archiver and it seemed to work …